Jump to content


2007 gsxr 600 Akrapovic shorty w/ pcV

2007 gsxr 600 akrapovic pcv

1 reply to this topic

#1 The Pure Word

    Newbie

  • Members
  • Pip
  • 2 posts
    Joined: 21-July 16
  • Location: maine
  • Bike: 2007 gsxr 600

Posted 08 August 2016 - 11:50 AM

Hey Folks,
This is my first post, so first of all HELLO. Im 38 years old from Maine. I've had bikes off and on for awhile, but I'm not a racer or even what I'd call a die hard rider. Over the years I've done entry level modifications, like fairing changes, turn signals, levers, etc. I am not a mechanic by any stretch.
Having said that, I recently picked up a 2007 gsxr 600 with 4k miles on it and I've been dumping some money into it to make it nice. I really do love customizing these gixxers. So I came on here to Motomummy and bought an akra shorty and a pcv. I wrote in the notes at purchase and asked them to please map it. I received my gear quickly and am very happy.
Not having had any confirmation as to whether or not Moto mapped my gear, I just went ahead and loaded the appropriate map off the site myself, just in case.
Here's what's happening: My bike sounds great. But when I get up into the 8k tac range, I lose acceleration power. It just stops climbing. So I top out around 85-90 mph. I can only assume this has to do with my mapping etc.
A few notes:
when installing pcv, I do not have an o2 censor, so there's a plug all the way to the right of my tank that I unplugged ( TPS ? ) , and ran inline as instructions said to, but there was no plug to replace it.
I have a stock air filter on now, but will soon be replacing it with a K&N that I have.
I am aware that it is recommended to have a dyno performed when installing pipes and pcv for best results, but I figured I'd be fine with what I've done, that although I may not see peak results, I'd see sufficient results for my riding level. I didn't think I'd see major performance LOSS. So I assume I've messed something up. Or maybe I have to do the dyno to get this gear to function, which I'll do if necessary.

I apologize if this topic has been discussed already somewhere. I searched and came up empty. And I really appreciate any advice you might be willing to take the time to offer.

Thanks,
Shawn

#2 The Pure Word

    Newbie

  • Members
  • Pip
  • 2 posts
    Joined: 21-July 16
  • Location: maine
  • Bike: 2007 gsxr 600

Posted 14 August 2016 - 12:29 PM

I'm receiving help on gixxer.com so I won't be checking this thread. Thanks.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users